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Pengenalan Macromedia Flash

A. Pengenalan Software untuk Animasi

Pada prinsipnya animasi dibuat dengan menggunakan berbagai gambar terpisah. Sementara gerakan
(motion) pada dasarnya adalah kumpulan dari gambar diam yang diurutkan sehingga menyerupai
obyek yang bergerak. Seperti halnya pada TV atau film, sebenarnya layar berkedip dengan kecepatan
tertentu dan menampilkan tiap-tiap gambar. Karena kecepatannya yang sangat tinggi, maka seluruh
gambar tergabung membentuk sebuah aliran adegan yang panjang.

Gambar web pada umumnya (seperti GIF atau JPEG) merupakan ‘bitmap’ yang terdiri atas titik-titik
warna tunggal (pixel) yang menyusun gambar sehingga sering timbul masalah seperti sulit dirubah
ukurannya tanpa mengurangi kualitasnya, kapasitas yang menyita banyak ruang, dan animasinya
merupakan sambungan sejumlah bitmap dalam satu file yang cukup besar, sehingga dalam kaitannya
dengan halaman web, akan memakan waktu yang lama untuk men-download-nya.

Flash merupakan software yang mampu menghasilkan file animasi dengan ukuran kecil. Hal ini terjadi
karena Flash merupakan program animasi vektor, maksudnya dibuat dari sejumlah bentuk yang
tersusun atas gambar dan warna. Selain lebih ekonomis ukuran file-nya, vector mudah dibentuk dan
digerakkan serta dapat ditampilkan bahkan dicetak dalam ukuran apapun.

Selain gambar dengan format vektor, Flash juga mampu menggabungkan teks, gambar bitmap, suara
serta elemen interaktif ke dalam movie.

Flash memiliki kemampuan untuk menyederhanakan proses animasi melalui penggunaan frame kunci
dan tweening. Maksudnya cukup dengan membuat titik awal dan akhir animasi, dan Flash akan
mengerjakan tween di antaranya.

B. Pengenalan Jendela Flash

1. Mengenal Menu Dasar
Berikut merupakan tampilan umum Flash dalam membuat movie.

Toolbar Layer Timeline Stage Properties Library
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e Toolbar

Panel yang umumnya muncul pada aplikasi-aplikasi grafis dan /ayout. Toolbar ini dibagi empat
kelompok: Tools; berisi tombol-tombol untuk membuat dan mengedit gambar, View; untuk

mengatur tampilan lembar kerja, Colors; menentukan warna yang dipakai saat mengedit,

Option; alat bantu lain untuk mengedit gambar.

e LlLayer

Berbagai /ayer akan diatur dan diurut di sini, di samping t&imeline. Tiga kolom di kanan setiap

nama /ayer menunjukan visibilitas setiap /ayer > icon - apakah itu dikunci (untuk
mencegah perubahan) > Jjcon 3, atau untuk mengeset tampilan dalam bentuk outline atau

warna > jcon |:|.

e Timeline

Bagian dari jendela aplikasi dimana /ayer dan frame diatur dalam satu bagian. Setiap /ayer
diurut ke bawah dalam timeline, sedangkan frame diurut secara melintang. timeline

digunakan untuk mengetahui panjang/durasi animasi.

e Stage

Layar kerja utama untuk melakukan pengeditan setiap frame dari movie Flash. Frame yang

dipilih di timeline akan muncul di /ayer ini.

e Properties

Berisi informasi suatu obyek dapat berupa karakter fisik gambar/garis (panjang dan lebar),
warna, serta teks editor (untuk jenis, ukuran serta warna fonf). Suatu obyek/gambar dapat
diedit melalui panel ini setelah terlebih dahulu obyek/gambar tersebut dipilih/diseleksi dengan

Selection Tool [ k ].

e Library

Di sinilah terkumpul berbagai simbol yang dipakai dalam animasi yang kita buat. Simbol

merupakan kumpulan gambar baik movie, tombol (button), dan gambar statis (graphic).

2. Fungsi tiap Tool pada Toolbar

Menyeleksi (memilih) gambar Menampilkan seleksi yang lebih detil

(sub-select)

Mengubah bentuk obyek
(memperbesar, memperkecil
atau memutar)

Mengubah arah gradasi

Memilih gambar secara tak beraturan

Membuat garis lurus \

Menggambar garis atau

Menyisipkan teks

bentuk tertentu

ada opsi pull-down
Membuat lingkaran/elips /O ® Psi & )

Membuat kotak segi empat atau polygon

Membuat garis tebal

Membuat gambar tak beraturan K
Pewarna badan (7i/) gambar
Mengubah warna garis (//he)/y Q\

Menghapus bagian gambar

Mengambil sampel warna
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3. Document Properties

Document Properties berguna sebagai persiapan pembuatan animasi. Fungsi Document Properties
adalah untuk melakukan pengaturan ukuran movie di layar, warna background dan framerate,
dan dimensi.

Untuk memanggil kotak dialog Document Properties, pilih jendela Properties di bawah layar,
kemudian pilih tombol Size.

i P Actions
% properties  Filkers | Parameters =
—
f Documernt Size: ‘ S50 = 400 pixels ' Background: | | Frame rate: fps
! )
Untitled-3 Publish: mﬁ_ Player: &  ActionScript: 2 Profile: Default
Device: Settings... ®

Judul dan deskripsi yang akan dimasukkan ke
dalam metadata output. Bukan merupakan
penamaan file jadi tidak perlu diisi.

Document Properties

Dimensi atau ukuran stage i
yang ingin ditampilkan 5

Description: |/
Pilihan Printer memaksimalkan ukuran
movie hingga area cetak penuh. Karena (width)  x (height)
output yang diinginkan berupa animasi dan T .

. o C D ' Prink Default
bukan print-out maka pilihan yang atch O printer © befa
diaktifkan adalah Default. .
Fos

Klik dan pilihlah warna yang tersedia
untuk mengubah warna stage — area
kerja Flash. oK | ’ el
Pastikan satuan yang aktif adalah Framerate yaitu kecepatan Flash dalam
Pixel Karena satuan inilah yang akan memutar animasi secara utuh yang diukur
digunakan. dalam fps (frame per second). Semakin besar

framerate maka semakin halus animasinya.
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Il. Pemanfaatan/Penggunaan Tool Gambar, Teks dan Warna

A. Menggambar Bentuk-bentuk Dasar

1. Membuat Garis

Flash menyediakan pilihan untuk membuat beragam bentuk garis. Pilih ikon Line Tool [ #* ] pada
toolbar di sisi kiri layar, kemudian lihat pilihannya di panel Properties di sebelah kiri bawah layar,
Masukkan angka ketebalannya. Dan untuk memulai garis klik pada stage dan drag sepanjang
yang anda inginkan.

hiairlin
Solid

i w Actions

£ ¥ properties  Filkers | Parameters

o Line + B |1 i | Solid i Cap: =

Tool [ strake hinting Scale; |\ Mormal w | Miter: Joim:

2. Pensil

Untuk membuat garis bebas, Pilih ikon Pencil Tool [¢] pada toolbar sisi kiri dan pilih warnanya
pada panel Colors di bawahnya. Untuk membuat garis lurus, pada panel Options di bawah
toolbar pilihlah opsi Straighten.

# Macromedia Flash Professional B - [Bentuk Dasan*]

File Edit Wiew Insert Modify Text Commands Conkrol Window Help

Toals Bentuk Dasar*

k& | Timeline | 5 Scene 1
Ll = = 4 0O s 10 15 z0 E
Ve Q [ ﬂ? |
& A
oo
rra
& & FrFee. i ¢ =T Fa [t t20fes | 00s
> P
Wiews
W Q
Calors
.
@ -— -— -— ————
L.
Options
Straighten
§  Smooth
e% Ik
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3. Lingkaran dan Kotak

Pilih Oval Tool [ O ] atau Rectangle Tool [ [0, ] untuk menaruh bentuk lingkaran, elips atau
kotak pada layar. Adapun jenis dan warna garis serta warna isi bentuk itu dapat dipilih pada panel

Colors.
Fle Edit ‘iew Insert Modfy Text Commands Control ‘Window Help
Eentuk Dasar*

kG |W| %Scenel

E &80 5 10 15 20 5
/s P ) 7 O

& A

oo

a4 _

& & B4 E] dr || f] @@ B 1 [1zofps | oo
2 g

Wiew

T Q

Colrs O

= MOR

G S ———
LR

Options

@l

23

4. Unik

Buatlah bentuk yang unik dengan menggunakan Pen Tool [ & 1. Klik, drag dan lepas, maka garis
akan terbentuk. Gerakkan kembali mouse ke arah yang diinginkan dan klik untuk membuat sudut
atau anchor point. Bila bentuknya merupakan kurva tertutup maka dapat diberi warna.

Z Macromedia Flash Professional B - [Bentuk Dasar*]
File Edit ‘iew Insert Modify Text Commands Control ‘Window Help

Taals Bentuk Dasar*

| Timeline | % Scene 1

= &40 5 10 15 20 =
? I 7 O
A
O

& I E | g || ¢ @lwl w1 [izofs | o

Colors O
7R

Oplions

@
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5. Menghaluskan

Siku dan bentuk kotak dapat dihaluskan dengan cara pilih Rectangle [, ] dan pilih Set Corner
Radius yang berada di bagian bawah panel. Masukkan nilai 5 dalam kotak dialog Rectangle
Setting dan pilih OK. Mulailah menggambar kotak dan hasilnya akan terlihat.

Taals Bentuk Dasar*

k& |W| 5 seene |
nE N B &40 5 10 1 0 =
V= [d 7 0
b A
O|s]
27|
& & s g || 4] @&lwl w e 1 [izofs [ o
2 g
View
O Q N o)
Colors Rectangle Settings D_(|
7R —
@ ] Carmer radius: paints ———
S
Options
@if.]
Fag

6. Mengubah Ukuran

Double-click bentuk yang akan diubah ukuran dengan menggunakan Selection Tool [ k]. Pilih
Free Transform Tool [[:1 ], maka pada ujung bentuk akan muncul kotak kecil atau handle. Pada
panel Option pilih opsi Scale [ 5] ]. Drag kotak kecil tersebut ke arah luar, ukuran akan
membesar dan drag ke arah dalam maka ukuran akan mengecil secara simetris.

Taals Bentuk Dasar
| Timeline | % Scene 1

&= 50 5 10 15 20 25
) v O

T i || 4 BT W G+ |tzofps | oos
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|
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7. Memutar

Untuk memutar bentuk, dengan Free Transform Tool [ I ] masih dalam keadaan aktif, Pilih
Rotate and Skew [#7] pada panel Option kemudian arahkan mouse mendekati salah satu
handle yang ada di sudut hingga cursor membentuk panah melingkar. Klik dan drag ke arah
putaran yang diinginkan.

EBentuk Dasar*
| Timeline | £ seene 1

i &40 5 10 15 20 5
[J i O

PRyt ||| ®E W 1 [zofs [ oo

> g

B. Menggunakan Warna

1. Mengganti Warna

Untuk mengganti warna isi atau garis dari bentuk yang telah dibuat dapat dilakukan dengan
menyeleksi/memilih bentuk yang akan diganti dengan menggunakan Selection Tool [ &k ].
Doubleklik gambar yang ingin diganti warnanya, kemudian pada panel Colors pilih opsi Stroke
Color [# B ] untuk mengubah warna garis atau pilih Fill Color [ & B ] untuk mengubah warna

isi bentuk.
Wi
O Q _
Colars O
ra |
é | e ——
#FFFFUU Alpha: [100% L EJ
[ |
N
[ |
N
||
N
[ [ ]
N
[ [ ]
IEE ® LCO0NS
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2. Gradasi

Untuk memberi warna gradasi, pilih menu Window > Color Mixer, jendela Color Mixer akan
muncul di sebelah kanan layar. Pilih bentuk yang akan diberi warna gradasi dengan Selection
Tool [ & ], pada pull-down menu di panel Color Mixer, pilih 7ype Radial. Pilih warna yang lebih

terang untuk bagian sebelah kiri, sedangkan bagian kanan yang lebih gelap.

ii w Calor =

Color Mixer

/W
Overﬂow:
6 m E

mEE [Clinear RGE

4
Ri| 285 | B
G| 255 |w
B:| 255 |v

Alpha: | 100% | | #FFFFFF

i P align & Info & Transform
i P Library

Untuk mengedit gradasi pilih Gradient Transform Tool |55 ]. Klik dan drag handle yang muncul

sesuai dengan arah yang diinginkan.

File Edit “iew Insert Modify Text Commands Control Window Help

Bentuk Dasar*
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C. Menggunakan Teks

Untuk menambahkan teks kedalam layer pilih Text Tool [ A ] pada foolbar kemudian klik pada
layar. Sebuah kotak kosong akan muncul. Untuk mengubah jenis, ukuran serta warna font, gunakan
jendela Properties di bagian bawah layar.

F Macromedia Flash Professional B - [Bentuk Dasar*]

File Edit W%ew Insert Madify Text Commands Control Window Help

Toals

Bentuk Dasar®

Rk | Timeline | 5 Seene 1 %v 48]'[
& &80 5 10 15 20 25 0 35 40 % 50
s 7 7 O

g A

=l
8
® & el i ||| dlw W e [eoems [0 €
& 7

Wien
o Q

Colors

/IR

e m —————
LIEy -

options

Pembuatan Animasi

it Actions

4% properties  Filkers | Parameters

| static Text v A A =95
-":,\" EIV al |N0rmal v| |Anti-alias Far readability v|
~ W:x: L [ auta kern
b ow[ems wlors | a | | Target:

D. Mengimpor Gambar dan Mengolahnya

1. Mengimpor Gambar

Untuk memasukkan gambar dalam format b/itmap, seperti misalnya foto, ke dalam movie dapat
dilakukan dengan cara mengimpor gambar/foto tersebut. Pilih menu File > Import> Import to
Stage, lalu cari letaknya di hard disk.

# Macromedia Flash Professional B - [Untitled-1]

FIEM Edit  View Insert  Modify Text Commands Control  window  Help

Mew, . Chrl4-m
Cpen... ChrlC
Cpen From Site.., ne 1
DOpen Recent 3
Close Chrl+i =20 s 1o 1= 1
Clase &l Chri+al-+w p O
Save Chrl+5
Save and Compact
Save As... Ctrl4-shift+5
Sawve as Template...
Save Al i || 4] Gl % G o 1z
Export 3 Import to Library. ..

Open External Library. .. Cerl4-Shift+0
Publish Settings... Crrl+-Shift+F12 " X ¥
y X Import Yideo. ..
Publish Preview | -
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2. Memperbesar/memperkecil

Untuk memperbesar atau memperkecil ukuran gambar dapat dilakukan dengan menggunakan
Scale Tool [ {1 ] pada toolbar disebelah kiri. Agar ukuran gambar tidak distorsi, tekan Shift

pada keyboard pada saat memperbesar/memperkecil gambar.

Z Macromedia Flash Professional B - [Untitled-1*]

File Edit “iew Insert Modify Text Commands Control Window Help

Untitled-1*
| Timeline | % Scene 1
=&0

b Bl Bl ] 1 [t20fs | o0s

SINOe N\,
WX O> Vit~

Cplions
f)
& &

3. Mengubah Bitmap menjadi Vektor (Trace Bitmap)

Dalam Flash terdapat fasilitas untuk mengubah gambar dalam format b/tmap menjadi vektor,
yaitu menu Trace Bitmap. Fasilitas ini berguna untuk mengurangi besarnya file karena
penggunaan gambar bitmap dalam animasi. Namun tentunya kualitas gambar b/itmap itu sendiri

akan mengalami penurunan.

Untuk mengaplikasi Trace Bitmap pada gambar/foto yang telah kita impor, sebelumnya

pilih/seleksi terlebih dulu gambarnya menggunakan Selection Tool [ k ] pada toolbar.

Kemudian pilih menu Modify > Bitmap > Trace Bitmap

# Macromedia Flash Professional 8 - [Untitled-1%]
File Edit Miew Insert BEGGIES Text Commands Control Window Help

Document. .. Chri+]

Unitled-14
kL ———  Convert ko Symbol,., F8
|Tlm—ellne Break Apart Chrl+B
-~
H = T
Eitrnap 3 Swap Bitmap..,
o [ Symbal 3 Trace Bitmap. ..
vl
0 A e
Combine Objects r
O 0O
Timeline b
f’ rd . Timeline Effects 3
2R E] |J B [ 1 [0k
@ $ Transform 3
ﬁ @ Remcecssss Arrange s
Align
Wiew
@ Q Graup Chrl+iz

Colors
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Setelah muncul kotak dialog T7race Bitmap, masukkan angka pada kolom Color Threshold dan
Minimum Area. Semakin besar angka yang dimasukkan semakin besar pula file yang dikompres.
Namun sebaiknya tidak memasukkan angka lebih kecil dari 10 (sepuluh) karena pengaruhnya
pada pengurangan besarnya file sebagai tujuan utama 7race Bitmap akan sangat kecil. Bahkan
pada beberapa komputer (dengan spesifikasi rendah) akan mengakibatkan Aang, karena
komputer dipaksa bekerja terlalu keras untuk menguraikan gambar tersebut.

Trace Bitmap E]

Color threshold:

Minirum area: pixels
Curve fit: |Nl:|rmal v|
Cornet threshold: |Nl:urmal v|

Setelah proses T7racing Bitmap selesai, pilih menu Modify > Group, agar gambar yang sudah di-
trace tersebut terkumpul sebagai satu /image.

# Macromedia Flash Professional B - [Untitled-1*]
File Edit Wiew Insert BEEGIES Text Commands Control window Help

Docurnent. .. Ctri+-1
e Unititled-14
k& —————  Convert to Symbal,.. F8
|T|Lhne Break Apart Ctrl+B
LI S
; 10
: Bitrmap +
7 P [J Symbaol 3
»
Q A Shape
Combine Objects 3
o0
Timeline 3
f f Timeline Effects 3
" [l
&z $ Transform 4
ﬁ .@ Arrange 3
Align 3
Wit
@ Q Group
Ungroup Chrl+Shift+G

4. Pengolahan Gambar lebih lanjut

Untuk mendapatkan gambar dengan hasil olahan lebih lanjut, disarankan untuk menggunakan
software lain yang memang dikhususkan untuk mengolah gambar/foto, seperti; Macromedia
Fireworks, Adobe Photoshop atau Corel Photopaint. Flash digunakan pada saat gambar
tersebut telah siap untuk dianimasikan.
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